• david® Exchange ActiveSync Test: Ein Zwischenbericht

    von  • 2. Mai 2014 • Blog • 20 Kommentare

    Seit etwa 3 Wochen haben wir die neue Exchange Active Sync Public Beta von Tobit david® nun im Einsatz. Als Clients dienen Windows Phone 8 und 8.1 Dev Preview, Android 4.0.x, Android 4.4 (Phone und Tablet), Windows Mail unter Windows 8.1 (PC, Notebook, Surface RT Tablet) und testweise Outlook 2013. Angebunden wurden Konten auf unserem Firmenserver (Windows Server 2008 R2 und seit letztem Wochenende Windows Server 2012 R2) und auf meinem privaten Server (Windows 8.1).

    Insgesamt sind die Erfahrungen mit dieser ersten Beta Version sehr positiv, wenngleich ein paar Dinge noch nicht zuverlässig funktionieren.

    Wie bereits in meinen Testberichten beschrieben, funktionieren nicht alle Features bei allen Clients. So konnte ich es Windows Phone z.B. nicht beibringen die Adressen zuverlässig zu synchronisieren.
    Auch gibt es scheinbar irgendein Problem mit meinem Firmenaccount, denn bei allen Clients / Geräten habe ich das Problem, dass ich keine Mails versenden kann. Ich habe bereits den Ausgang geleert und eine manuelle Bereinigung durchgeführt, aber auch das hat leider nicht geholfen.
    Bei meinen privaten Account und den Accounts der Kollegen klappt das problemlos.

    Bei Windows Phone 8 (bzw. zwischenzeitliches Update auf WP 8.1 Developer Preview) haben beide Konten (Privat und Firma, unterschiedliche Server) irgendwann aufgehört zu aktualisieren. Auch über mehrere Tage ist da nichts mehr passiert. Nach Löschen und neu Anlegen waren wieder alle Daten da. Beim ersten auftreten hat es nach der Grundsynchronisation direkt wieder gestreikt. Aktuell läuft es wieder.

    Unter Windows Phone 8 gab es zwischenzeitlich auch Probleme mit den Mail Apps selbst. Nach einrichten der David Active Sync Konten stürzten teilweise die Mailapps ab (an zwei verschiedenen Geräten und unterschiedliche Userkonten). Unter Windows Phone 8.1 hatte ich diesen Effekt nicht mehr.

    Bei meinem Android 4.0.4 kamen manche Mails 3x an. Beim Kollegen mit Android 4.4 lief alles bestens.
    Outlook 2013 stürzte je nach Konto nach kurzer Zeit ab und die Adressen wurden nicht synchronisiert.

    Wie man sieht gibt es durchaus noch einige Baustellen. Ich bin gespannt wie sich dies entwickeln wird und wie man hört soll schon in Kürze ein neues RollOut mit einer neuen ActiveSync Version veröffentlicht werden – neben Verbesserungen im Umgang mit den verschiedenen Clients soll auch der Abgleich von Terminen implementiert sein.

    Man darf also durchaus gespannt sein wie fleißig man in Ahaus war und hoffen das die oben genannten Probleme damit behoben werden.

    20 Responses to david® Exchange ActiveSync Test: Ein Zwischenbericht

    1. 18. Juni 2014 von 14:37

      Hallo,
      vielen Dank für den Zwischenbericht! Gibt es hier schon was neues?
      Mittlerweile sind ja schon 2-3 Rollouts verstrichen.
      Weiß man schon, wann der Kalender implementiert wird?

    2. 18. Juni 2014 von 15:39

      Hallo Sönke,

      in den Release Notes der Rollouts steht auch immer einiges drin, einfach mal rein schauen wenn was Neues da ist.
      Kalender werden seit dem vorletzten Rollout abgeglichen, seit dem letzten auch die Aufgaben und Notizen (gibt es m.W.n. nur im iPhone).
      Des Weiteren kann je nach Client ein Autoreply eingerichtet werden.
      Mit WP gibt es noch Probleme in Sachen Adressen (wenn diese über die DvAPI erzeugt wurden) und mit den Anhängen.
      Sonst läuft alles sehr gut.

      Gruß Jens

    3. Reiner Armbruster
      11. Juli 2014 von 11:12

      Hallo,

      habe seit kurzem ein Nokia 625 mit WP 8.

      Die synchronisieren läuft sehr langsam. Adressen (ca.3000) nur teilweise, eMail vom Tag vorher, Kalender zur Zeit noch keine Termine

      Habt ihr da noch Info was wir noch Testen können.

      Grüße Reiner

      • 11. Juli 2014 von 18:27

        Hallo Reiner,

        teste mal das Rollout von heute, damit ist EAS nicht mehr Beta und es wurden noch einige Sachen verbessert / gefixt.

        Gruß Jens

    4. Reiner
      15. Juli 2014 von 15:40

      Hallo Jens,
      nach dem Rollout sieht es jetzt viel besser aus. Jetzt habe ich nur noch folgendes Problem das ich ab und zu den Fehler bekomme, Synchronisierungsfehler. Beim Synchronisieren der Daten ist ein Problem aufgetreten. Versuchen sie es später erneut.
      Übersprungene Elemente:
      Abgelegt unter: Wolf Eugen
      Der Kontakt konnte nicht mit dem Handy synchronisiert werden.

      Die Meldung kommt 4x mit verschiedenen Adressen.

      Jetzt habe ich die Adressen in meinem David Server in einen anderen Ordner verschoben. Nur die Meldung kommt immer noch mit den gleichen Adressen.
      Auf dem Handy sind die Adressen nicht.

      Grüße aus Berghaupten

      • 15. Juli 2014 von 16:05

        Hallo Reiner

        mit den Adressen klappt es bei uns auch noch nicht mit Windows Phone und teilweise nicht bei Android…
        Ich stehe dazu noch in Kontakt mit Tobit. Am besten meldest Du das auch mal, je mehr da was sagen umso höher die Chance das was passiert.

        Gruß Jens

      • Reiner
        16. Juli 2014 von 11:37

        Hallo Jens,
        habe mich bei Tobit gemeldet und bin per Intercom schon in Kontakt.
        Grundsätzlich funktioniert die Synchronisation von Adressen bei mir. Kann Adressen auf dem WP8 anlegen oder ändern und die Änderungen werden synchronisiert. Auch wenn ich im David Client Änderungen vornehme.

        Den Synchronisierungsfehler bekomme ich hauptsächlich wenn ich im WP8 in dem eMail Client die synchronisation manuell betätige.

        Gruß Reiner

    5. Harry
      30. Juli 2014 von 12:11

      Hallo Jens,

      ich habe Probleme mit dem EAS.
      Ich habe einen Bintec Router danach eine Firewall und dann den Davidserver.
      mit dem Davidclient kann ich problemlos auf den Server zugreifen.
      Nur EAS geht nicht. Ich habe 443 im Router auf den Server weitergeleitet.
      Die Firewall lässt 443 auch durch.
      Aber beim Einrichten des Kontos heißt es immer
      ‚Verbindung zum Server kann nicht geöffnet werden‘
      Im Router kommt die Anfrage an und er schickt es auch weiter an den Davidserver.
      Dort sehe ich aber nichts. Im Protokoll von der Webbox erscheint auch bei ‚vollständig‘ nichts.
      Gibt es noch irgendwo Einstellungen im David zu machen?

      Grüße Harry

      • 30. Juli 2014 von 12:50

        Hallo Harry

        passiert den von Intern etwas? Falls nein, ist in der Webbox der Haken „TLS deaktivieren“ gesetzt?
        Falls etwas passiert wird es wohl am Bintec liegen. Wie siehst Du, dass die Anfragen weitergeleitet werden?
        Wichtig ist hier, dass man nicht nur die Firewallregel erstellt, sondern auch einen Eintrag unter Netzwerk->NAT->NAT Konfiguration (Portforwarding).
        Es müssen also immer zwei Einträge gemacht werden, das Portforwarding und die Erlaubnis in der Firewall.

        Gruß Jens

    6. harry
      30. Juli 2014 von 14:13

      Hallo Jens,

      vielen Dank. Es war der Haken bei „TLS deaktivieren“ gesetzt.

      Grüße Harry

    7. Harry
      30. Juli 2014 von 14:48

      Hallo Jens,

      jetzt hab ich doch noch eine Frage.
      Ich kann mit beliebigen Androidphones zugreifen.
      Nur bei einem Nokia Lumia mit WP8.0 erhalte ich auf dem Phone die Fehlermeldung,
      das etwas mit dem Zertifikat nicht stimmt.
      Kann ich da im David noch was einstellen?
      Im Android habe ich die Möglichkeit beliebige Zertifikate zu akzeptieren,
      das habe im in WP8 nicht, oder gibt es da noch eine versteckte Einstellung?

      Grüße Harry

    8. Harry
      30. Juli 2014 von 14:51

      Hallo Jens,

      das Problem hat sich erledigt.
      Ich habe die Einstellung gefunden.

      Vielen Dank

      Harry

    9. Mario
      27. August 2014 von 14:11

      Hallo!

      Hat jemand schon auf Android 4.1.2 oder 4.2.2 Gruppenkalender zu laufen gebracht. Der Kalender des jeweiligen Benutzers funktioniert reibungslos, aber nicht die gemeinsam genutzten Gruppenkalender. Habe schon alles mögliche ausprobiert, im Zugriff per Webbox funktioniert auch alles noch soweit.
      Hat jemand ne Idee?

      Gruß
      Mario

      • 27. August 2014 von 18:04

        Hallo Mario

        funktioniert der Zugriff auf die Gruppenkalender denn im Webaccess?
        In den meisten Fällen wird vergessen die Remote Access Daten anzupassen.

        Zum einen muss der Remote Access auf dem Gruppenkalender natürlich aktiviert werden. Zum anderen müssen die Daten die man dort eingibt mit denen des Hauptaccount (der Active Sync Account) übereinstimmen. Ist das nicht der Fall, schlägt der Zugriff fehl.
        Wenn man mit mehreren Usern auf einen Gruppenkalender zugreift oder auch die Userkalender untereinander verknüpft, dann hat man natürlich das Problem, dass man verschiedene Accountdaten hat. In diesem Fall aktiviert man den Remoteaccess auf dem Gruppenkalender (oder den Userkalendern), aber lässt die Felder Benutzername und Passwort leer. Dadurch gibt es hier keine Authentifizierung und der Zugriff funktioniert.
        Ein Sicherheitsproblem ist das nicht, da die Kalender nicht direkt erreichbar sind, sondern immer nur über den Useraccount, der ja die Daten hinterlegt hat.

        Gruß Jens

      • Mario
        3. September 2014 von 19:30

        Hallo Jens,

        bitte entschuldige die Verspätung…

        Accountdaten sind soweit gesetzt, funktionierte soweit ja auch alles von Remote oder im Browser
        Es gibt im Client (5185) in den Optionen unter Einstellungen – Zugang- ActiveSync neue Einträge:
        – Adress-Ordner-zusammenfassen
        – Kalender- Ordner zusammenfassen
        – Aufgaben- Ordner zusammenfassen
        Sind diese Optionen gestzt, dann funktionieren verknüpfte Kalender und Adressordner. Aufgaben wahrscheinlich auch, aber damit arbeite ich nicht… (Allerdings habe ich hier noch ein S4 Actve, mit 4.2.2 da will es einfach nicht klappen…)
        Leider sind diese Optionen nicht dokumentiert. Außerdem sollten diese Einstellungen in der Benutzerverwaltung verfügbar sein, da ja ein ActiveSync Benutzer nicht unbedingt auch den Client zur Verfügung hat!
        Jetz bin ich mal auf das heutige Update gespannt!

        MfG!

      • 6. September 2014 von 12:49

        Hallo Mario

        bei uns funktionieren die Gruppenkalender auch unter Android 4.2.2 ohne die Ordner zusammen zu fassen.
        Aber es gibt leider unterschiedliche Implementierungen von Active Sync, so dass verschiedene Geräte unterschiedlich reagieren.
        Wir haben hier z.B. immer noch das Problem mit den Adressen die per DvAPI erzeugt wurden. Wir haben 4 Android Geräte im Test, 2x 4.4.4 cyanogenmod und 2x 4.4.2 Tablets, einmal Samsung, einmal Onda.
        Beim Samsung (wie auch beim iPhone) werden die Adressen synchronisiert, bei den anderen drei Geräten und 2 Lumias nicht. Unter Windows 8 Kontakte wiederum gehts…

        Die Verbesserungsvorschläge solltest Du im Intercom an Tobit richten, ebenso Dein konkretes Problem. Wir können speziell bzgl. der Verbesserungsvorschläge nichts machen.

        Gruß Jens

    10. Mario
      8. September 2014 von 08:33

      Hallo Jens,

      ja sicher, ich habe das schon per Intercom gemeldet….

      Vielen Dank!

      Mario

    11. luc
      22. Dezember 2014 von 01:15

      Warum sollte man, wenn man die Exchange Funktionalitäten von Tobit nutzen möchte überhaupt Tobit benutzen? Sollte man, wenn man Exchange haben möchte nicht einfach Exchange benutzen? Eine Software die seit Jahren auf dem Markt ist und mit so ziehmlich jedem Gerät bereits seit Jahren kompatibel ist? Warum baut Tobit eine Software nach, die es bereits schon besser auf dem Markt gibt? Denn günstiger ist die Lösung von Tobit nicht. Eher teurer oder bin ich da falsch informiert?

      • 22. Dezember 2014 von 15:27

        Hallo Luc

        Tobit hat Exchange nicht nachgebaut. Im Gegenteil, David ist Exchange seit Jahren in vielen Bereichen voraus. In anderen hinkt es zugegebenermaßen hinterher.
        Was Tobit aktuell gemacht hat ist, das Exchange Active Sync PROTOKOLL zu lizenzieren (sie bezahlen da eine Gebühr an MS für die Nutzung) um die Anbindung von Mobilgeräten zu realisieren.
        Warum sollte man das Rad neu erfinden, wenn es bereits ein gut funktionierendes gibt – zumal EAS in allen Handys standardmäßig implementiert ist.

        Übrigens nutzen auch diverese andere Anbieter das EAS Protokoll, wie z.B. Kerio im Mailserver Kerio Connect oder bis vor einigen Monaten sogar Google zur Anbindung von Google Konten.

        Gruß Jens

      • luc
        5. Januar 2015 von 10:11

        Naja, besser spät eine Einsicht als nie.

    Schreibe einen Kommentar

    Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.