• david® Exchange ActiveSync Test: Windows Phone und Android

    von  • 13. April 2014 • Blog • 23 Kommentare

    Hier also wie angekündigt die ersten Tests. Fangen wir mit Windows Phone an.

    Windows Phone 7/8 (Samsung Omnia 7 und Nokia Lumia 920)
    Das neue Konto wird im Windows Phone über Einstellungen->E-Mail-Konten & andere->Konto hinzufügen->Outlook (Outlook.com, Exchange, Office 365) hinzugefügt.
    Nach der Eingabe von E-Mailadresse und Passwort kann man nach zwei fehlgeschlagenen Verbindungsversuchen (sofern euer Domainroot nicht direkt auf den Davidserver zeigt) über die erweiterten Einstellungen auch die Serveradresse angeben. Als Zugangsdaten kommen die Remote Access Daten des entsprechenden Users zum Einsatz. Der Rest sollte selbst erklärend sein.

    Bei Windows Phone 7 gibt es ein kleines Problem. Hier MUSS man zwingend eine Domäne angeben. Die Prüfung schlägt dann aber fehl, da die Remote Access Daten von David nichts mit der Windows Domäne zu tun haben. Durch einen kleinen Trick konnte ich den Account dennoch einrichten. Ich habe den Benutzernamen im Remote Access einfach entsprechend geändert, z.B. „servername\username“ und im WP Client dann im Feld „Domäne“ den gleichen Eintrag wie „servername“ hinterlegt.

    E-Mail
    Die Erstsynchronisation kann je nach Verbindung und Datenmenge etwas dauern. Sind einmal alle Daten synchronisiert, zeigt ein Blick auf die Ordnerstruktur, dass hier wirklich alle persönlichen Ordner korrekt angezeigt werden und sich auch synchronisieren lassen.

    Über die Verknüpfungen hat man sogar Zugriff auf öffentliche Order, wenn man diese verknüpft hat.
    Neu eintreffenden E-Mails werden mit nur wenigen Sekunden Verzögerung angezeigt (sofern die Option „Bei Eintreffen“ aktiviert wurde), versendete E-Mails landen ordnungsgemäß im Ausgang (und nicht wie bei IMAP OS abhängig in Ordnern wie „Send Items“, o.ä.), der Gelesen Status wird korrekt synchronisiert und auch das Löschen und Verschieben von E-Mails funktioniert einwandfrei.
    Es ist sogar möglich eine Kennzeichnung zu setzen, so wie es zuletzt auch bei IMAP implementiert wurde. Hierdurch bekommt die Nachricht im David Windows Client eine grüne Fahne als Markierung.

    Ein Problem gibt es aktuell noch bei Anhängen. Diese konnten bei meinen Tests mit verschiedenen Konten nicht heruntergeladen werden.

    Adresse
    Bei meinem eigenen David Account konnten keine Adressen mit Windows Phone abgeglichen werden. Es kam zu einem Synchronsiationsfehler der sogar den gesamten Abgleich (auch Mail) verhinderte. Erst mit der Deaktivierung der Kontakte in den Synchronisationseinstellungen funktionierte der Abgleich der Mails. Bei meinem privaten David Server und dem privaten David Account hatte ich das gleiche Problem.

    Um das ganze noch einmal gegen zu prüfen habe ich dann mit einem neuen User getestet. Hier funktionierte die Synchronisation der Adressen wie man sich das vorstellt. Das Anlegen funktioniert auf beiden Seiten und der Abgleich ist sehr schnell – auch hier ohne große Verzögerung.

    Das einzige Problem das ich hier feststellen konnte ist der Abgleich von Kontaktfotos, sofern diese auf dem Windows Phone hinzugefügt wurden – von David zum Windows Phone klappt auch dies.

    Kalender
    Obwohl in den Release Notes angegeben ist, dass die Terminsynchronisation in dieser Version noch nicht enthalten ist, sieht man zumindest in den Kalendereinstellungen die Kalender, die abgeglichen werden sollen. Hierbei ist interessant, dass nicht nur der eigene, sondern auch Gruppenkalender angezeigt werden. Allerdings stimmen diese noch nicht ganz, da hier nicht die direkt verknüpften Ordner angezeigt werden, sondern deren Unterordner. Aber wie gesagt, diese Funktion kommt erst mit einem der nächsten Rollouts.

    Aufgaben
    Hier passiert noch gar nichts. In den Release Notes ist davon auch nichts zu lesen. Bleibt zu hoffen, dass der Abgleich der Aufgaben überhaupt geplant ist.

    Einstellungen
    Windows Phone bietet in den Mailkontoeinstellungen die Möglichkeit eine „automatische Antwort“ zu konfigurieren. Bei Kerio Connect wird hiermit ein Autoreply am Server eingerichtet.
    Aktuell kommt hier nur eine Fehlermeldung. Ich bin mal gespannt ob diese Funktion auch implementiert wird, wünschenswert wäre es auf jeden Fall, damit man den Autoreply auch von unterwegs aktivieren kann.

     

    Android 4.0.4 (Samsung Galaxy S Duos aka GT-S7562)
    Die Einrichtung des Active Sync Accounts unter Android 4.0 erfolgt über den Typ „Microsoft Exchange ActiveSync“. Auch hier werden zunächst wieder E-Mailadresse und Passwort verlangt. Mit der anschließenden Fehlermeldung hat man die Möglichkeit die Details zu bearbeiten und die Serveradresse anzugeben. Im letzten Schritt wählt man die zu synchronisierenden Objekte wie E-Mail, Kontakte, Kalender, etc.

    E-Mail
    Auch bei Android funktioniert das arbeiten mit E-Mails so wie man sich das vorstellt, inklusive dem Zugriff auf öffentliche Bereiche über die Verknüpfungen.
    Gegenüber Windows Phone klappt hier auch der Zugriff auf die Anhänge.

    Allerdings hatte ich bei meinem David Account das Problem, dass E-Mails nicht versendet werden konnten. Mit dem angelegten Testaccount klappte auch dies.

    Adressen
    Bei Android wurden im Gegensatz zum Windows Phone alle 186 Adressen meines persönlichen Adressordners synchronisiert.
    Das Problem mit den Kontaktfotos gibt es auch hier. Werden auf Androidseite Fotos zu einem Kontakt hinzugefügt, verschwinden diese kurz nach speichern wieder. Da scheint also noch ein Bug vorzuliegen.

    Kalender
    Auch hier werden bereits die zu synchronisierenden Kalender angezeigt, allerdings nur der Hauptordner, nicht die verknüpften Gruppenkalender. Aber wie oben erwähnt ist der Terminsync auch noch nicht implementiert.

    Aufgaben
    Hier passiert wie bei Windows Phone noch nichts.

    Einstellungen
    Auch hier meldet die Einstellung der Autoreply Funktion einen Fehler.

     

    Fazit
    Was ich bisher gesehen habe ist sehr vielversprechend. Die Grundfunktionen klappen schon sehr gut und teilweise besser als die anderen Schnittstellen nach etlichen Jahren.
    Ich bin gespannt wie die Umsetzung des Kalenderabgleichs realisiert wird, denn darin steckt viel Potential hinsichtlich der Arbeit mit Gruppenkalendern.
    Auch bin ich gespannt ob der Abgleich von Aufgaben implementiert wird und Sonderfunktionen wie das Einstellen eines serverseitigen Autoreplies.

    Interessant dürfte auch werden, wie man die Fehler lösen kann, die bei mir aufgetreten sind. Da diese bei neu angelegten Benutzern nicht aufgetreten sind, ist davon auszugehen, dass man hier selber Hand anlegen muss und ich schätze ich bin nicht der einzige bei dem dieser Fehler auftritt. Ich werde versuchen die Probleme mit meinem Account zu lösen und darüber berichten, wenn es mir gelungen ist.

    Wie sind eure Erfahrungen mit der ersten Public Beta von Exchange ActiveSync für david®?

    23 Responses to david® Exchange ActiveSync Test: Windows Phone und Android

    1. Reiner Armbruster
      15. April 2014 von 17:20

      Hallo,
      habe das auf dem Iphone getestet und funktioniert Problemlos. (eMail)

      Hat schon einer Versuche mit WIN 8.1 gemacht. Hier bekomme ich nur die Meldung“ Verbindung kann nicht hergestellt werden“

      Grüße Reiner

      • 16. April 2014 von 22:01

        Hallo Reiner,

        ich habe ein bisschen mit Windows Mail und Outlook 2013 unter Win8.1 getestet, aber auf beiden wollte die Verbindung nicht klappen.
        Bzw. hat es bei meinem privaten Server und Mailkonto irgendwann mit Windows Mail geklappt, obwohl ich nichts anders gemacht habe.
        Ich konnte aber auch noch nicht genau prüfen, versuche das die Tage noch mal anzugehen.

        Gruß Jens

        PS: Unter Windows Phone 8.1 klappt es auch.

      • 19. April 2014 von 11:16

        Kurze Ergänzung hierzu: Windows Mail erfordert zwingend ein SSL Zertifikat.
        Ich werde dazu noch einen Beitrag veröffentlichen.

      • Reiner Armbruster
        19. April 2014 von 12:13

        Hallo Jens ,

        Danke für die Info.

        Grüße Reiner

    2. oliver gessner
      23. Juli 2014 von 22:01

      Hallo,
      auf meinem Android Telefon habe ich die Einrichtung hinbekommen. Auf meinem neuen Nokia 630 kriege ich es einfach nicht hin. ;-(

      • 24. Juli 2014 von 09:12

        Lumia 630?
        Was genau klappt denn nicht?
        Deaktiviere testweise mal den Sync von Adressen in den Einstellungen des Kontos.

    3. Reiner
      3. November 2014 von 21:54

      Hallo Jens,
      bei mir hat es eine ganze Zeit sehr gut funktioniert. Seit dem Wochenende habe ich folgenden Fehler,
      auf meinem WP8,1, Nokia Lumia 930, Fehlercode: 85002012
      unter David, Ergeignisse von David Webbox, No Request since 0 0:09:36.

      Hast du da eine Idee an was das liegen kann.

      Grüße Reiner

      • 3. November 2014 von 23:17

        Hallo Reiner

        navigiere mal auf Fileebene in Dein Userverzeichnis und lösche da die ActiveSync.db. Danach klappt es meist wieder.
        Die Daten werden dadurch neu synchronisiert, es gibt aber keine Dubletten, keine Angst. Habe das bereits ein paar mal gemacht.

        Ich hoffe da tut sich noch was…hast Du schon das Rollout von Freitag installiert?

        Gruß Jens

      • Reiner Armbruster
        4. November 2014 von 11:56

        Hallo Jens,
        bei mir hat es nicht gebracht die ActiveSync.db zu löschen. Was mache ich mit der ActiveSync.usr soll ich die auch löschen.

        So langsam nervt das mit dem Exchange ActiveSync. Was für Möglichkeiten gibt es sonnst noch mit dem WP8.1

        Grüße Reiner

      • 4. November 2014 von 12:53

        Hallo Reiner

        die usr habe ich nicht gelöscht, wohl aber den Eintrag unter Webbox->Active Sync für mein Phone.
        Viele Alternativen gibt es nicht. IMAP oder POP für Mails und Webaccess. That’s it.

        Gruß Jens

      • Reiner Armbruster
        4. November 2014 von 13:47

        Hallo Jens,
        die Meldung erscheint jetzt im WebBox Status Monitor,
        SSL accept Failed: 00001200

        habe ich ein Problem mit dem Zertifikat. Habe eines selber erstellt mit „TLSCERT“

        Was benutzt ihr für Zertifikate, wo kann man ein geeignetes Zertifikat kaufen.

        Das Update vom 31.11.2014 habe ich gestern schon installiert.

        Gruß Reiner

      • 4. November 2014 von 20:49

        Hallo Reiner

        ich habe das von Startssl.com benutzt. Das einfachste ist sogar umsonst.
        Testweise aber auch einfach mal ohne SSL probieren.
        Wenn alles nichts hilft, dann musst Du wohl den Account auf dem Phone mal löschen und neu einrichten.

        Gruß Jens

      • Reiner armbruster
        4. November 2014 von 23:45

        Hallo Jens,
        auch das löschen des Account auf dem Nokia Lumia WP 8.1 hat nichts genutzt. Es geht einfach nichts mehr und von Tobit hört man auch nichts. So langsam verliere ich die Lust mit der Sch……..

        Danke für deine Hilfe

        Grüße Reiner

      • 5. November 2014 von 01:26

        Hallo Reiner

        das hat dann aber ziemlich sicher einen anderen Hintergrund. Denn spätestens das neu anlegen ist wie ein Reset und hat bisher immer geholfen.
        Hast Du mal ohne SSL getestet? Habt ihr was am Router / Internetleitung verändert?
        Hast Du mal mit einem anderen Gerät oder z.B. Windows Mail (klappt bei mir sehr zuverlässig) probiert? Auch hier am besten erst einmal ohne SSL.

        Vielleicht sollten wir das hier auch besser ins Forum verlagern. 😉

        Gruß Jens

      • Reiner Armbruster
        5. November 2014 von 07:12

        Hallo Jens,
        ich habe es noch nicht bohne SSL getestet. Ich dachte bisher dass WP 8.1 nicht ohne SSL geht. Am Router heben wir nichts geändert. Mit Windows Mail geht es bei mir auch ohne Probleme. Hier aber auch nur mit SSL.

        Wie kann ich das ins Forum verlagern ??

        Grüße Reiner

      • 7. November 2014 von 12:56

        Hallo Reiner,

        schau mal, es gibt heute ein neues Rollout und in den Notes ist dies hier zu finden:
        „Bei der Nutzung von ActiveSync auf Windows Phone 8 Geräten konnte es u.U. zu Abbrüchen bei der Synchronisierung kommen.“

        Habe es gerade erst gelesen und werde jetzt testen. Ich habe auch seit Dienstag Stillstand bei zwei Konten.

        Gruß Jens

      • Reiner Armbruster
        7. November 2014 von 13:53

        Hallo Jens,
        nach dem Update von heute Funktioniert es wieder. Hatte heute morgen einen Telefontermin mit Tobit. Der hat aber nichts gesagt wegen dem neuen Update.
        Habe dafür Gebühren tel. Unterstützung pro Min. (Night) Netto USt. 37,70 bezahlt und es hat eigentlich nichts gebracht!!

        Danke für den Hinweis von dir

        Gruß Reiner

      • Reiner Armbruster
        9. November 2014 von 16:22

        Hallo Jens,

        bis jetzt funktioniert es sehr gut. Ohne Probleme und ich habe das Gefühl dass es viel schneller ist wie vorher.

        Gruß Reiner

      • 10. November 2014 von 21:25

        Hallo Reiner

        das hört sich doch sehr gut an. Mein Firmenaccount funktioniert bisher ebenfalls sehr gut und auch die Adressen klappen jetzt (ich hatte hier Probleme mit den Adressen, die unser work4all-David Konnektor per DvAPI erzeugt).
        Das private Konto auf dem privaten David Server zickt noch…

        Gruß Jens

    4. Suat
      5. November 2014 von 14:47

      Hallo zusammen,

      versuche gerade Active Sync auf einem Android Gerät (Samsung S3) einzurichten. Will aber irgendwie nicht klappen. Welche Mail-App habt Ihr verwendet? Die native Samsung-App. Mit der probiere ich es. Ich bekomme zwar die Fehlermeldung Verbindung zum Server nicht möglich. Sehe aber im Status Monitor der Webbox dass die Verbindung zum Server aufgebaut wird. Allerdings steht hinter „path“ nichts. Also gehe ich davon aus, dass nicht erkannt wird, welcher Benutzer hier angesprochen wird.

      In der Android-App unter Feld Domäne\Benutzer steht bei mir nur \s.bodur (wobei s.bodur der Benutzername ist mit dem ich für den Remotezugriff eingerichtet bin.) Aber auch wenn ich nur „s.bodur“ eintrage klappt es nicht.

      Der Remotezugriff über einen Browser oder über die David-App funktioniert einwandfrei. Mit den gleichen Zugangsdaten die ich auch für Active Sync verwende.

      Woran also kann es liegen?

      Danke im Voraus.

      • 7. November 2014 von 12:59

        Hallo Suat

        das hört sich soweit alles ok an und sollte so auch klappen.
        Hast Du die Möglichkeit das EAS Konto mal in Windows Mail (Win8) oder einem anderen Gerät zu testen?
        Ansonsten auch mal einen anderen User testen, bei dem es noch nicht gemacht wurde, z.B. mit dem Admin.

        Gruß Jens

    5. Tatjana
      5. Dezember 2014 von 13:38

      Hallo zusammen!
      Ich versuche gerade, den active sync auf dem Samsung Galaxy Note 4 einzurichten. Es erscheint immer die Fehlermeldung „Aktivierung fehlgeschlagen“. Der VPN-Zugang steht. Mit den gleichen Daten, die im Note 4 eingegeben wurden funktioniert der Zugang auf dem Nexus 7 und iphone 4s einwandfrei. Hat jemand eine Idee, was ich in den Einstellungen ggf. ändern muss??

      Vielen Dank im Voraus.
      Viele Grüße

      • 6. Dezember 2014 von 18:08

        Hallo Tatjana

        funktioniert denn der Zugriff auf andere Dienste in eurem Netzwerk über diese VPN Verbindung? Vielleicht ist da noch was falsch eingestellt…?
        Wenn es auf den anderen Geräten geht, sollte es auch auf dem Galaxy Note klappen, daher vermute ich eine anderen Fehlerquelle.
        Man könnte im Webbox Monitor mal prüfen, ob die Kommunikation ankommt.
        Ohne auf das System drauf zu schauen wird es schwer das zu lösen denke ich.

        Gruß Jens

    Schreibe einen Kommentar

    Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.